Serviceeinschränkung bei Signierung, Service degregation for signature process
Incident Report for Deutsche Fiskal
Resolved
Deutsche Version - English version below


Sehr geehrte Fiskal Cloud Nutzer,

wir freuen uns, Ihnen mitteilen zu können, dass auch die letzten Tests nun erfolgreich abgeschlossen werden konnten und die neue FCC Version 4.0.4. ab heute Mittag zum Download bereitgestellt wird. Sie können ab 13 Uhr mit den Tests in den Testkonten starten.
Ebenso sind die offiziellen BSI Zertifikate bereits auf der Internetseite des BSI veröffentlicht.

Folgendes ist hierbei zu beachten:
Alle FCC Versionen 4.0.1. und 4.0.2. können als Update auf die neue Version 4.0.4. umgestellt werden.
Alle FCC Versionen 3.x. müssen neu installiert werden und können nicht als Update auf die neue Version umgestellt werden. (Dies gilt nur für die Nutzung einer Cloud TSE, Token Nutzer sind hiervon nicht betroffen)

Die Fiskalisierung ist mit der neuen FCC Version 4.0.4. wieder vollständig einsatzbereit.

Im Laufe der kommenden Woche wird unser Partner Bundesdruckerei ein offizielles Schreiben erstellen, welches die Umstände und die Dauer des Ausfalls dokumentiert und von allen Kunden als Nachweis genutzt werden kann.
Wir werden dieses Schreiben dann unaufgefordert per Email an alle Nutzer versenden.

Wir danken für Ihre Geduld und Ihr Verständnis.

Mit freundlichen Grüßen
Ihr DF Support Team



English version:

Dear Fiscal Cloud users,

we are pleased to inform you that the last tests have now also been successfully completed and the new FCC version 4.0.4. will be available for download as of noon today.
The official BSI certificates are already published on the BSI website. You can start testing in your test accounts from 1 pm today.

Please note the following:
All FCC versions 4.0.1. and 4.0.2. can be updated to the new version 4.0.4.
All FCC versions 3.x. must be reinstalled and cannot be switched to the new version as an update. (This only applies to the use of a cloud TSE, token users are not affected by this).

Fiscalization is fully operational again with the new FCC version 4.0.4.

During next week, our partner Bundesdruckerei will prepare an official letter documenting the circumstances and duration of the outage, which can be used as proof by all customers.
We will then send this letter to all users via email without being asked.

We thank you for your patience and understanding.

With kind regards
Your DF Support Team
Posted Aug 18, 2022 - 11:40 CEST
Update
Deutsche Version - English version below

Sehr geehrte Nutzer der Fiskal Cloud,

nachfolgend der aktuelle Sachstand 17.08.22 zum Ausfall:

Die FCC Version 4.0.4. wurde heute fertiggestellt. Wir planen die umfangreichen Tests sowie die QA morgen abzuschließen und das release im Laufe des morgigen Tages zu veröffentlichen sofern die Tests erfolgreich sind.

Wir werden Ihnen morgen im Laufe des Tages eine finale Information zum Stand der Versionsfreigabe und der Zertifizierung auf gleichem Weg zukommen lassen.

Mit freundlichen Grüßen
Ihr DF Support Team


English version:

Dear users of the Fiscal Cloud,

please find below the current status regarding the outage for today:

The build of the FCC version 4.0.4. was completed today. We plan to complete the extensive testing and QA tomorrow and release it in the course of tomorrow in case of the completion of the QA.

We will send you final information on the status of the version release and certification in the same way tomorrow.

With kind regards
Your DF Support Team
Posted Aug 17, 2022 - 18:35 CEST
Update
Deutsche Version - English version below

Sehr geehrte Nutzer der Fiskal Cloud,

nachfolgend der aktuelle Sachstand 16.08.22 zum Ausfall:

Es ist geplant die neue FCC Version 4.0.4. heute fertigzustellen und bis morgen final zu testen. Wir planen die Auslieferung im Laufe des 17.08.22.

Dabei wurde bereits erfolgreich getestet, dass ein Update auch mit einem FCC im sogenannten temporären Secure State funktioniert und somit keine Neuinstallation aufgrund dieses Systemzustands notwendig ist.

Ebenso ist es unserem Partner Bundesdruckerei gelungen durch engen Austausch mit dem BSI die Zertifizierung voranzutreiben, welche abgeschlossen wurde.

Wir werden Ihnen morgen im Laufe des Tages eine finale Information zum Stand der Versionsfreigabe und der Zertifizierung auf gleichem Weg zukommen lassen.

Mit freundlichen Grüßen
Ihr DF Support Team


English version:

Dear users of the Fiscal Cloud,

please find below the current status regarding the outage for today:

The build of the new FCC version 4.0.4. shall be completed by today cob and will then enter the final internal testing phase. We plan to deliver it in the course of 17.08.22.

It has already been successfully tested that an update also works with an FCC in the so-called temporary secure state and thus no reinstallation is necessary due to this system state.

Our partner Bundesdruckerei has also succeeded in advancing the certification with the BSI, which has been completed successfully.

We will send you final information on the status of the version release and certification in the same way tomorrow.

With kind regards
Your DF Support Team
Posted Aug 16, 2022 - 17:44 CEST
Update
Deutsche Version - English version below

Sehr geehrte Nutzer der Fiskal Cloud,

nachfolgend der aktuelle Sachstand 12.08.22 zum Ausfall:

Die neue FCC Version 4.0.3. steht im Developer Portal nun zum Download bereit. Alle Tests wurden erfolgreich abgeschlossen.
Bitte beachten Sie, dass diese Version ab jetzt bis zur nächsten Kundeninformation nur in der Testumgebung installiert werden kann (für kundeninterne Tests), da die Produktionsumgebung noch gesperrt ist.

Sobald die Zertifizierung durch das BSI vollständig vorliegt, wird unser Partner Bundesdruckerei auch die Produktionsumgebung wieder freischalten.
Dazu wird es eine gesonderte Ankündigung über diesen Kanal geben.


Mit freundlichen Grüßen
Ihr DF Support Team


English version:

Dear Fiskal Cloud users,

Below is the current status 12.08.22 on the outage:

The new FCC version 4.0.3. is now available for download in the Developer Portal. All tests have been successfully completed.
Please note that from now until the next customer information, this version can only be installed in the test environment (for customer internal tests), as the production environment is still locked.

As soon as the certification by the BSI is completed, our partner Bundesdruckerei will also unlock the production environment.
There will be a separate announcement about this via this channel.


With kind regards
Your DF Support Team
Posted Aug 12, 2022 - 14:28 CEST
Monitoring
Sehr geehrte Nutzer der Fiskal Cloud,

nachfolgend der aktuelle Sachstand 11.08.22 zum Ausfall:

Die neue FCC Version 4.0.3. ist fertiggestellt und befindet sich nun in der finalen internen Testphase. Es bleibt bei der Auslieferung im Laufe des 12.08.22.

Dabei wurde bereits erfolgreich getestet, dass ein Update auch mit einem FCC im sogenannten temporären Secure State funktioniert und somit keine Neuinstallation aufgrund dieses Systemzustands notwendig ist.

Ebenso ist es unserem Partner Bundesdruckerei gelungen durch engen Austausch mit dem BSI die Zertifizierung voranzutreiben, welche voraussichtlich schon morgen abgeschlossen werden kann.

Wir werden Ihnen im Laufe des Tages eine finale Information zum Stand der Versionsfreigabe und der Zertifizierung auf gleichem Weg zukommen lassen.

Mit freundlichen Grüßen
Ihr DF Support Team


English version:

Dear Fiskal Cloud users,

the following is the current status 11.08.22 regarding the outage:

The new FCC version 4.0.3. has been completed and is now in the final internal testing phase. It remains with the delivery in the course of 12.08.22.

It has already been successfully tested that an update also works with an FCC in the so-called temporary secure state and thus no reinstallation is necessary due to this system state.

Likewise, our partner Bundesdruckerei has been able to achieve first parts of the certification through close exchange with the BSI, which is expected to be completed as early as tomorrow.

We will send you a final information about the status of the version release and the certification in the same way during the course of the day.

With kind regards
Your DF Support Team
Posted Aug 12, 2022 - 09:11 CEST
Update
Deutsche Version - English version below

Sehr geehrte Nutzer der Fiskal Cloud,

nachfolgend der aktuelle Sachstand 10.08.22 zum aktuellen Ausfall

Unser Partner Bundesdruckerei hat heute Vormittag die neue SMAERS-Version an die DF Deutsche Fiskal übermittelt und wir erstellen auf dieser Basis nun die neue FCC-Version 4.0.3.
Diese wird im Anschluss intensiven Tests unterzogen und es bleibt bei der geplanten Bereitstellung am 12.08.22.

Die Abstimmung mit dem BSI läuft noch. Zum jetzigen Zeitpunkt liegen uns dazu keine neuen Informationen vor und wir werden uns unverzüglich melden, sobald neue Fakten dazu vorliegen.

Das nächste Update erfolgt im Laufe des 11.08.22.

Mit freundlichen Grüßen
Ihr DF Support Team



English version:

Dear users of the Fiscal Cloud,

the following is the current state of affairs for today August 10th 2022 regarding the current outage

This morning, our partner Bundesdruckerei transmitted the new SMAERS version to DF Deutsche Fiskal and we are now creating the new FCC version 4.0.3 on this basis.
This will then be subjected to intensive testing and it remains with the planned provision on 12.08.22.

The communication with BSI is still ongoing. At this point in time, we do not have any new information on this and will report immediately as soon as new facts are available.

The next update will be in the course of 11.08.22.

With kind regards
Your DF Support Team
Posted Aug 10, 2022 - 17:02 CEST
Update
Sehr geehrte Nutzer der Fiskal Cloud,

nachfolgend der aktuelle Sachstand zum heutigen Ausfall der Signierung sowie der weiteren Vorgehensweise:

Wie bereits heute Mittag erwähnt, wurde der Ausfall durch ein Code signing Zertifikat innerhalb der vom BSI zertifizierten SMAERS-Komponente verursacht.
Das neue Zertifikat liegt unserem Partner Bundesdruckerei seit 30min vor und wird nun von der BDR Entwicklung in die SMAERS Komponente integriert.
Die neue SMAERS Version wird dann am 10.08.22 an die DF Deutsche Fiskal ausgeliefert und am 11.08. umfangreich getestet so dass bei erfolgreichem Test die neue FCC Version 4.0.3. am 12.08. zum Download bereitgestellt werden kann.

Nach aktuellem Kenntnisstand muss die neue SMAERS Komponente einen verkürzten Zertifizierungsprozess des BSI durchlaufen und vom BSI abgenommen werden.
Die Kollegen der Bundesdruckerei sind dazu mit dem BSI in enger Abstimmung, um dies schnellstmöglich vorzunehmen. Ein genauer Fertigstellungstermin kann jedoch zum jetzigen Zeitpunkt nicht genannt werden.
Sobald wir hierzu neue Informationen bekommen, geben wir Ihnen diese unverzüglich weiter.

Dies bedeutet aber auch, dass ein Update der momentan genutzten FCC Versionen auf die neue Version 4.0.3. unvermeidlich ist und vorgenommen werden muss, damit die Fiskalisierung technisch wieder funktioniert.

Zum momentanen Situation der nicht vorhandenen Fiskalisierung ist zu erwähnen, dass die regulatorischen Vorgaben erfüllt sind, sofern auf dem Kassenbon der Ausdruck erfolgt, dass die TSE ausgefallen oder nicht erreichbar ist.
Dieser Ausfall ist durch den Steuerpflichtigen zu dokumentieren und seitens der Bundesdruckerei wird im Nachgang noch ein offizielles Schreiben erstellt, welches die Ausfallzeiten und die Ursache belegen wird.

Mit freundlichen Grüßen
Ihr DF Support Team



English version:
Dear Fiscal Cloud users,

Please find below the current state regarding today's signing failure and the further course of action:

As already mentioned today at noon, the failure was caused by a code signing certificate within the BSI certified SMAERS component.
The new certificate has been available to our partner Bundesdruckerei since 30min and is now being integrated into the SMAERS component by the BDR development team.
The new SMAERS version will then be delivered to DF Deutsche Fiskal on 10.08.22 and will be extensively tested on 11.08. so that, if the test is successful,
the new FCC version 4.0.3. can be published for downloading on 12.08.22

According to the current state of knowledge, the new SMAERS component has to go through an abbreviated certification process of the BSI and has to be accepted by the BSI.
Our colleagues at Bundesdruckerei are working closely with the BSI to ensure that this is done as quickly as possible. However, it is not possible to give a precise completion date at the present time.
As soon as we receive new information on this, we will pass it on to you without delay.

However, this also means that an update of the currently used FCC versions to the new version 4.0.3. is unavoidable and must be carried out so that the fiscalization technically works again.

Regarding the current situation of non-existent fiscalization, it should be mentioned that the regulatory requirements are met, provided that on the receipt there is a printout that the TSE has failed or is not accessible.
This failure has to be documented by the taxpayer and on the part of Bundesdruckerei an official letter will still be issued afterwards, which will prove the downtime and the cause.

Kind regards
Your DF Support Team




Die Ursache konnte in der Zwischenzeit identifiziert werden. Es handelt sich um ein abgelaufenes Code Signing Zertifikat innerhalb der vom BSI zertifizierten SMAERS-Komponente.
Dieses Zertifikat wird nun ausgetauscht und wir erhalten schnellstmöglich von unserem Partner BDR eine neue Version.

Dies bedingt auch, dass wir Ihnen eine neue FCC Version 4.0.3. bereitstellen müssen, welche dann als Update der bestehenden FCC Version 4.x oder auch 3.x installiert werden muss.
Im Laufe des Nachmittags werden wir weitere Informationen von unserem Partner BDR erhalten und Ihnen dann zum Abend hin eine weitere Kundeninformation bereitstellen können.
Posted Aug 09, 2022 - 18:19 CEST
Update
We are continuing to work on a fix for this issue.
Posted Aug 09, 2022 - 18:19 CEST
Update
Deutsche Version – English version below

Sehr geehrte Fiskal Cloud Nutzer,

hiermit möchten wir Ihnen ein Update zum aktuellen Ausfall geben.

Die Ursache konnte in der Zwischenzeit identifiziert werden. Es handelt sich um ein abgelaufenes Code Signing Zertifikat innerhalb der vom BSI zertifizierten SMAERS-Komponente.
Dieses Zertifikat wird nun ausgetauscht und wir erhalten schnellstmöglich von unserem Partner BDR eine neue Version.

Dies bedingt auch, dass wir Ihnen eine neue FCC Version 4.0.3. bereitstellen müssen, welche dann als Update der bestehenden FCC Version 4.x oder auch 3.x installiert werden muss.
Im Laufe des Nachmittags werden wir weitere Informationen von unserem Partner BDR erhalten und Ihnen dann zum Abend hin eine weitere Kundeninformation bereitstellen können.

Mit freundlichen Grüßen
Ihr DF Support Team



English version:
Dear Fiscal Cloud users,

we would like to give you an update on the current outage.

In the meantime the root cause could be identified. It is an expired code signing certificate within the BSI certified SMAERS component.
This certificate will now be replaced and we will receive a new version from our partner BDR as soon as possible.

This will also require us to provide you with a new FCC version 4.0.3. which will then need to be installed as an update to the existing FCC version 4.x or even 3.x.
In the afternoon we will receive further information from our partner BDR and will then be able to provide you with further customer information in the evening.

With kind regards
Your DF Support Team
Posted Aug 09, 2022 - 13:25 CEST
Identified
Sehr geehrte Fiskal Cloud Nutzer,

wie Sie bereits bemerkt haben, gibt es aktuell eine Störung bei der Signaturerstellung.
Es handelt sich hier um ein Problem mit einem Zertifikat innerhalb des zertifizierten SMAERS-SW.
Wir arbeiten gemeinsam mit unserem Partner Bundesdruckerei an der Lösung und werden Sie diesbzgl. auf dem Laufenden halten.

Mit freundlichen Grüßen
Ihr DF Support Team



Dear Fiscal Cloud users,

as you have already noticed, there is currently a malfunction in signature creation.
This is a problem with a certificate within the certified SMAERS-SW.
We are working together with our partner Bundesdruckerei on a solution and will keep you informed.

Kind Regards
Your DF Support Team
Posted Aug 09, 2022 - 09:30 CEST
Investigating
Dear Fiskal Cloud user, currently we are facing signature issues and the service is degregated.
We are investigating the issue.
Posted Aug 09, 2022 - 08:08 CEST
This incident affected: CSP BDR Signaturservice.